Alignment API: Libraries shipped with the package (release 4.6)

The Alignment API uses a number of external libraries. These libraries are shipped (in the lib directory) with the Alignment API. Each subdirectory of the lib directory contains Project Object Models (POM) which provide information about the version, license and dependencies for these libraries.

We provide here the list of these libraries together with the reason why they may be necessary within the API and some other information.

Some of these libraries are necessary for recompiling the Alignment API. Some of them are only needed at runtime when invoking the feature that uses them. You may use this information for restricting the libraries to only the one you need.

Here is a picture of the various dependencies involved:

This is a simplified view: click here for the full graph generated by Tattletale.

Required for the API implementation (procalign)

Commons CLI 1.2: commons-cli.jar [Apache]
Library for parsing command line arguments. Required for the command line use (cli package; included by OWL-API).
SLF4J 1.7.5: slf4j-api.jar log4j-over-slf4j.jar jcl-over-slf4j.jar [MIT license]
Java unified logging library!

Required for using EDOAL

Jena 2.9.0: jena.jar iri.jar arq.jar [Apache]
Provides the RDF parser.
Xerces 2.11.0: xercesImpl.jar resolver.jar xml-apis.jar [Apache]
Required by Jena for parsing international characters.

Required for some bundled matching methods

OntoSim 2.4: ontosim.jar [LGPL]
The whole ontosim system requires more libraries, including JWNL. But in our simplest behaviour, these libraries are not needed.
Lucene 4.6.0: lucene-core.jar, lucene-analyzers-common.jar [Apache]
This small part of lucene is used for WordNet matching classes.

Required for the WordNet addition (JWNLAlignment)

In addition to OntoSim, JWNLAlignment requires JWNL.

JWordNet (JWNL) 1.4rc2: jwnl.jar [BSD]
This also requires WordNet to be installed in the computer.

Required for reasoning with alignments

DRAOn (or IDDL) 1.5: iddl.jar [LGPL]
In turns it requires HermiT.
HermiT 1.3.8: hermit.jar [LGPL]
Provides OWL Reasoning. It requires the OWL API.

Required for parsing ontologies (ontowrap)

Ontowrap requires one of these libraries to be functional. It will only compile if all of them are available. However, it is possible to delete the subdirectories src/fr/inrialpes/exmo/ontowrap/xxxx and this will compile again.

OWL API 3.4.8: owlapi-bin.jar [LGPL]
Provides parsing and API to OWL entities. Used by OWLAPIAlignments. api.jar is required for compiling, the others are necessary for executing parts of the Alignment API which need the OWL API.
OWL API 1.4.3: rdfapi.jar rdfparser.jar api.jar impl.jar io.jar [LGPL]
Provides parsing and API to OWL entities. Used by OWLAPIAlignments. api.jar is required for compiling, the others are necessary for executing parts of the Alignment API which need the OWL API.
Jena
is also an option.

Required for the Alignment server (alignsvc)

MySQL JDBC Connectors 5.1.28: mysql-connector-java.jar [GPL] or Postgres JDBC connectors 9.3-1100: postgres-jdbc4.jar [BSD]
This also requires MySQL to be installed. Required for alignsvc.
Jetty 9.1.4: jetty-server.jar jetty-http.jar jetty-io.jar jetty-util.jar [Apache]
Required for HTTP management (HTML, REST, Web service).
Servlet API 3.1: servlet-api.jar [CDDL + GPLv2 with classpath exception]
Required and shipped with Jetty. This is part of Java 2 Enterprise Edition
Commons fileupload 1.3.1 and Commons IO 2.4: commons-fileupload.jar, commons-io.jar [Apache]
Required and shipped with Jetty. This is part of Java 2 Enterprise Edition
Apache Commons Lang 3.3: commons-lang3.jar [Apache]
Required for escaping strings for various formats (XML, JSON)

Required for the Agent/JADE plug-in

Java Agent Development Environment (JADE) 3.7: jade.jar http.jar iiop.jar [LGPL]
Required by alignsvc (Agent version).

Required for the Web service plug-in

Required for the P2P/JXTA plug-in

Required for the OSGI plug-in

OSGi core framework 5.0.0: osgi-core.jar [Apache]
Required by alignsvc (OSGi version).

http://alignapi.gforge.inria.fr/lib.html

$Id: lib.html 1959 2014-07-16 07:57:01Z euzenat $